Back to overview
Maintenance

Email infrastructure maintenance

Jun 2, 2026 at 8:00pm UTC  –  Jun 3, 2026 at 3:00am UTC
Affected services
SMTP

Resolved
Jun 3, 2026 at 3:00am UTC

Maintenance ended

Updated
Jun 3, 2026 at 2:19am UTC

So far no regression and downtime has been monitored and no reports has been submitted. We are finishing deploying the update and testing now.

Updated
Jun 3, 2026 at 2:18am UTC

We are monitoring the new update and proceeding to test the new update before completing the maintenance.

Created
Jun 2, 2026 at 8:00pm UTC

We will be doing a maintenance regarding our email infrastructure. During this maintenance window, some emails may be delayed or not delivered. While we understand the impact this may cause to your workflow, we will be monitoring to mitigate the impact to our users. No other updates will be provided, unless regression or degradation during maintenance is happening.